network

Setting VPN di Mikrotik Untuk Game Garena

Ditulis oleh Beri komentar Lihat komentar

Sebagaimana yang di ketahui bersama bahwa beberapa waktu ini ada masalah koneksi (sebenarnya sih bukan masalah) antara ISP (produk IndiHome Telkom) yang tidak dapat digunakan secara maksimal untuk keperluan koneksi game Garena Indonesia (Point Blank, League of Legends, FIFA, dan sebagainya).

Permasalahan ini terjadi semenjak adanya “tuntutan” dari KPAI untuk memblokir game-game online yang mengandung atau mengajarkan kekerasan – termasuk di dalamnya game Point Blank yang lisensinya di pegang oleh Garena Indonesia.

Konon, pihak Telkom telah mengimplementasikan blocking untuk game ini. Hasilnya adalah koneksi game akan menjadi patah-patah, lag, atau ping jadi merah. Hehehe…

Meskipun pihak Telkom belum mengkonfirmasi hal ini, “kejadian” lagging saat bermain game di laporkan merata di seluruh Indonesia raya khusus untuk pengguna IndiHome. Namun berbeda dengan IndiHome, bagi pengguna ISP lain tidak di temukan masalah lag/leg pada saat memainkan game dari Garena Indonesia.

Oleh karena itu, pihak pengelola warnet dan online gamecenter beramai-ramai menggunakan fasilitas VPN agar masalah lag bisa teratasi.

Setting VPN di Mikrotik Untuk Game Garena

Secara spesifik saya akan secara singkat menjabarkan setting VPN di mikrotik untuk semua game Garena Indonesia.

Kelebihan teknik ini :

  • Mengatasi masalah lag bukan hanya pada game Point Blank, tapi juga semua game-game Garena Indonesia (League of Legends, FIFA, dan sebagainya).

Kekurangan teknik ini :

  • Menggunakan seluruh alokasi blok IP PT. Garena Indonesia (AS58816), sehingga IP address game, IP address website, dan sebagainya akan tercover secara keseluruhan. Dalam kondisi seperti ini, patcher juga akan mengambil patch via VPN, hasilnya trafik VPN saat patching akan menjadi penuh (bisa di atasi dengan limit koneksi, silakan google ya!).

Persiapan setting VPN di Mikrotik Untuk Game Garena

  • Sudah memiliki akun VPN (ada banyak yang jual kok.. silakan cari sendiri, hehehe). Saat membeli VPN, biasanya si penjual akan menginformasikan protokol VPN yang di gunakan (PPTP, L2TP, dan sebagainya) beserta IP address, username, password, atau pre-shared key (PSK) nya.

Setting VPN di Mikrotik Untuk Game Garena

Pertama, pengaturan dial VPN pada interface. Untuk pengguna VPN L2TP, silakan copas script berikut ini (sesuaikan IP address, username, password, dan PSK/ipsec).

/interface l2tp-client
add connect-to=xxx.xxx.xxx.xxx disabled=no ipsec-secret=xxxxxxxxx mrru=1600 name=VPN-IIX \
 password=xxxxxxxxx use-ipsec=yes user=xxxxxxxxx

Untuk pengguna VPN PPTP, silakan copas script berikut ini (sesuaikan IP address, username dan password).

/interface pptp-client
add connect-to=xxx.xxx.xxx.xxx disabled=no max-mru=1420 max-mtu=1420 mrru=1600 name=VPN-IIX \
 password=xxxxxxxxx user=xxxxxxxxx

Jika password, username, dan IP address yang di masukkan benar, maka akan tampil informasi interface dengan nama VPN-IIX dan status “R”

vpn-garena-01

Kedua, set statik routing untuk IP address milik Garena Indonesia ke VPN yang sudah kita set sebelumnya. Bisa langsung copas script berikut ini di terminal mikrotik.

/ip route
add comment=Garena distance=1 dst-address=43.252.184.0/22 gateway=VPN-IIX
add comment=Garena distance=1 dst-address=103.248.56.0/22 gateway=VPN-IIX
add comment=Garena distance=1 dst-address=202.73.16.0/21 gateway=VPN-IIX

vpn-garena-02

Next, set masquerade untuk trafik VPN

/ip firewall nat
add action=masquerade chain=srcnat comment="Masquerade VPN IIX" out-interface=VPN-IIX

garena-vpn-05

Terakhir, test traceroute! Jika VPN berjalan mulus akan terlihat traceroute yang berbeda antara Garena dengan situs lain, seperti gambar di bawah ini.

vpn-garena-03

Oke.. enjoy your VPN! Kalo VPN nya bagus, maka koneksi ke Garena akan menjadi lebih stabil dan no lag. :)

vpn-garena-04

Tips dan trik VPN untuk Garena!

  • Hapus OpenVPN bawaan dari Garena agar tidak pakai dobel VPN (Control Panel > Add / remove Program > TAP interface).

 


Related Posts

Filed under

Networking

| Tags:

,

  1. jadi mesti beli software vpn dong ya?

    • VPN di mikrotik bisa di jalankan tanpa pake software tambahan. Mungkin yang lebih pas, istilahnya adalah beli akun VPN. :)

Leave a Comment