utorrent

Remote µTorrent Web GUI di Belakang Mikrotik

Ditulis oleh Beri komentar Lihat komentar

Mikrotik memiliki fitur NAT hairpin yang memungkinkan kita untuk mengakses server dengan layanan tertentu (misalnya webserver, mailserver, dns server, dan sebagainya). Berikut ini adalah catatan kecil saya tentang pengaturan NAT hairpin yang pas untuk meremote µTorrent web interface. FYI, saya menjalankan µTorrent client di mesin virtual yang di host di kantor :)

Topologi

  • µTorrent client IP address : 192.168.80.1
  • Port µTorrent web interface : 82
  • IP address mikrotik : 192.168.80.200
  • IP internet/wan : 202.101.0.90 (ini contoh saja, hehehe)

topologi

FYI, Saya sebenarnya sudah mencoba pengaturan hairpin NAT seperti yang dijabarkan di wiki, akan tetapi tidak berhasil.

Untuk konfigurasi di NAT, saya menggunakan script di bawah ini :

/ip firewall nat
add action=dst-nat chain=dstnat comment="µTorrent client/seedbox" dst-port=82 protocol=tcp to-addresses=192.168.80.1
add action=src-nat chain=srcnat src-address=192.168.80.1 to-addresses=202.101.0.90
add action=masquerade chain=srcnat dst-address=192.168.80.0/24 src-address=192.168.80.0/24

Penampakan hasilnya di winbox

nat

Penampakan web interface µTorrent saat di akses dari internet (karena IP isp bersifat statik, jadi saya melakukan pointing A record di domain agar lebih mudah saat di remote).

webinterface

Finally, bisa diakses dari mana saja. By the way, cara ini juga mungkin bisa anda terapkan pada saat melakukan pengaturan CCTV agar bisa di akses dari internet.

Semoga bermanfaat!

 


Related Posts

Filed under

Mikrotik

| Tags:

Leave a Comment