routerbox

Konfigurasi Transparent DNS Terpisah di Mikrotik

Ditulis oleh Beri komentar Lihat komentar

Oke, sebenernya saya agak kesulitan menentukan judul dari posting ini, hehehe. Apa yang akan saya coba sampaikan adalah sebuah kasus yang pernah saya temukan pada saat melakukan setting mikrotik sebagai gateway internet di sebuah perusahaan. Saya di request agar komputer Boss-nya otomatis pake DNS google, sedangkan clientnya dipaksa pakai DNS nawala.

Untuk hal ini dapat dilakukan konfigurasi transparent DNS di gateway/mikrotik.

Konfigurasi Transparent DNS Terpisah di Mikrotik

Contoh kasusnya adalah sebagai berikut :

  • Semua klien baik yang dari hotspot atau yang tersambung menggunakan kabel di paksa untuk pakai DNS nawala.
  • Sedangkan laptop, gadget dan komputer “boss” di perusahaan tersebut di arahkan ke DNS google.

Pertanyaannya, bagaimanakah cara melakukan redirect / pengarahan secara otomatis setting DNS tersebut dengan menggunakan Mikrotik?

Jawabannya sebenernya cukup mudah kok, cukup di bikinkan ketentuan seperti ini :

  • Tentukan IP address punya boss/admin perusahaan, bisa dengan menggunakan pengaturan IP statik di sisi gadget. laptop dan komputernya atau juga bisa dengan menjadikan ARP dan IP address nya statik (jika menggunakan DHCP).
  • Tentukan kelas IP address klien juga.
  • Tambahkan kedua tipe IP address di atas ke address-list
  • Gunakan network address translation (NAT) untuk menangkap dan me-redirect koneksinya.

Dalam contoh kasus ini, IP address yang digunakan adalah sebagai berikut :

  1. IP address perangkat milik boss/admin (3 perangkat) : 192.168.0.20, 192.168.0.21, dan 192.168.0.22
  2. Kelas IP address milik klien adalah 192.168.0.0/24 (selain admin/boss)
  3. DNS google : 8.8.8.8 / 8.8.4.4
  4. DNS nawala : 180.131.144.144 / 180.131.145.145
  5. IP gateway / mikrotik : 192.168.0.1

Konfigurasi Transparent DNS Terpisah di Mikrotik

Berikut scriptnya untuk melakukan transparent DNS yang terpisah di mikrotik.

Pertama, enable DNS server di mikrotik, tujuannya agar query DNS klien semuanya dilakukan oleh mikrotik. Selain itu mikrotik juga akan melakukan caching query DNS, sehingga klien bisa lebih efisien dan lebih responsif pada saat browsing internet.

/ip dns
set allow-remote-requests=yes servers=180.131.144.144,180.131.145.145
/ip dns static
add address=192.168.0.1 name=internal.gateway.lan

Kedua, tambahkan address-list untuk perangkat milik boss/admin. Untuk klien nggak perlu di tambahkan, karena sifat rule di NAT adalah selain admin/boss di belokkan ke nawala, nggak peduli pake IP address yang mana.

/ip firewall address-list
add address=192.168.0.20 list=Admin
add address=192.168.0.21 list=Admin
add address=192.168.0.22 list=Admin

Selanjutnya, kita bikin NAT untuk membelokkan query DNS dari client dan boss.

/ip firewall nat
add action=dst-nat chain=dstnat comment="DNS Admin" dst-port=53 protocol=udp \
 src-address-list=Admin to-addresses=8.8.8.8 to-ports=53
add action=dst-nat chain=dstnat dst-port=53 protocol=tcp \
 src-address-list=Admin to-addresses=8.8.8.8 to-ports=53
add action=dst-nat chain=dstnat comment="DNS Clients" dst-port=53 protocol=udp \
 src-address-list=!Admin to-addresses=192.168.0.1 to-ports=53
add action=dst-nat chain=dstnat dst-port=53 protocol=tcp \
 src-address-list=!Admin to-addresses=192.168.0.1 to-ports=53

Di rules NAT ini kita menambahkan 2 protokol, yaitu UDP dan TCP, karena untuk query DNS biasa, protokol yang digunakan adalah UDP, sedangkan untuk query DNS dengan DNSSEC menggunakan protokol TCP.

Contoh penampakan di NAT, perhatikan yang di bagian kotak merah (yang ini intercept nya cuman UDP):

dns-query

Konfigurasi Transparent DNS Terpisah di Mikrotik

Oke, masalah sudah selesai disini! Jika kita mengaktifkan DHCP, gunakan 192.168.0.1 sebagai primary DNS nya, sedangkan untuk secondary DNS bisa di isi dengan 180.131.144.144.

Dengan setting seperti diatas, maka semua perangkat boss/admin akan di arahkan ke DNS google, sedangkan klien akan diarahkan ke Nawala, walaupun klien secara manual menyetting primary dan secondary DNS di perangkat yang mereka pakai secara manual.


Related Posts

Filed under

Mikrotik

| Tags:

  1. bagus bingit tutorialnya aa’.. (y)

Leave a Comment