You are here: Home » Mikrotik » Networking » Menonaktifkan Google SSL Search Lewat Mikrotik

Menonaktifkan Google SSL Search Lewat Mikrotik

December 29, 2012 | Leave a comment(16) Go to comments

Salah satu fitur dari mesin telusur Google adalah melakukan pencarian dengan SSL (Secure Sockets Layer) – dengan kata lain, pengguna mesin pencari google dapat menginput kata kunci dan menampilkan hasil pencariannya secara terenkripsi. Tujuannya tidak lain adalah agar privasi pengguna dapat terlindungi sepenuhnya. Secara default, Google akan menyeting modus penelusuran menggunakan SSL jika kita telah login ke salah satu layanan Google. Akan tetapi, pencarian terenkripsi seperti ini secara default seluruh konten didalamnya tidak dapat di cache oleh proxy server seperti squid.

Nah, bagi anda yang menggunakan server proxy didalam jaringannya, sudah pasti bandwidth yang tersedia tidak dapat dioptimasi dengan baik pada saat banyak user atau klien melakukan pencarian dengan menggunakan SSL. Namun, jika anda menggunakan mikrotik, anda dapat sedikit bernapas lega, karena ada cara yang mudah untuk menonaktifkan Google SSL search ini. Sehingga setiap user atau klien mengakses pencarian dengan SSL maka klien akan dialihkan ke pencarian tanpa menggunakan SSL.

“SSL (Secure Sockets Layer) is a protocol that helps provide secure Internet communications for services like web browsing, e-mail, instant messaging, and other data transfers. When you search over SSL, your search queries and search traffic are encrypted so that intermediary parties that might have access to your network can’t easily see your results and search terms”. – Google.

Menonaktifkan Google SSL Search Lewat Mikrotik

Untuk menonaktifkan pencarian Google SSL lewat mikrotik silakan ikuti prosedurnya sebagai berikut :

  1. Login-lah kedalam routerboard kesayangan anda lewat winbox.
  2. Klik pada opsi “IP”, kemudian klik opsi “DNS”.
  3. Pada menu DNS Settings, klik pada opsi “Static”.
  4. Selanjutnya, pada menu DNS Static, klik tanda tambah “+”.
  5. Dikolom “Name” isikan www.google.id dan “Address” isikan 216.239.32.20, kemudian klik “OK”
  6. Buat lagi satu entry DNS statik dengan mengklik “+” dengan “Name” www.google.com dan “Address” 216.239.32.20

Biar nggak bingung silakan lihat screenshot dibawah ini (klik untuk memperbesar).

mikrotik-disable-google-ssl-search

Buat yang pengen nggak mau ribet melakukan input dns statik secara manual, silakan copas script berikut di terminal :

/ip dns static
add address=216.239.32.20 name=www.google.com
add address=216.239.32.20 name=www.google.co.id

How it works?

Silakan baca spoiler berikut ini :

“To utilize the no SSL option for your network, configure the DNS entry for www.google.com to be a CNAME for nosslsearch.google.com” – Google

Nah, keterbatasan mikrotik adalah implementasi static CNAME dan agar dapat menonaktifkan SSL Search dari Google, saya menggunakan entri DNS statik dengan alamat IP yang digunakan oleh nosslsearch.google.com.

“As the solution, you may set IP address for static DNS entry to RouterOS IP, and then use dst-NAT + webproxy to redirect that http request to any website you want”. Chupaka – Mikrotik Forum.

Evaluasi dan pengetesan

Untuk mengetes konfigurasi yang kita terapkan, silakan login kesalah satu layanan Google (Youtube, Gmail, dan sebagainya) kemudian lakukan pencarian di internet seperti biasa. Jika berhasil, maka akan tampil pemberitahuan bahwa penelusuran SSL mati (dinonaktifkan) seperti gambar dibawah ini.

mikrotik-disable-google-ssl-search-test

Dalam kondisi seperti ini pencarian google akan menggunakan modus HTTP biasa, dan konten dari Google akan dapat di cache secara normal oleh mesin proxy.

Kekurangan dan Kelebihan

Kelebihan :

  • Secara teknis, jika kita menonaktifkan pencarian/penelusuran Google dengan SSL maka konten statis dari Google (berupa javascript, css, atau gambar statis) akan dapat di cache dengan baik oleh mesin proxy.
  • Jika caching dapat dijalankan dengan baik oleh mesin proxy, diharapkan penggunaan bandwidth akan menjadi lebih efisien dan terutilisasi dengan optimal.

Kekurangan :

  • Penelusuran SSL tersedia untuk semua top-level domain Google (bukan hanya .com atau .co.id saja) sehingga penelusuran SSL dapat dilakukan dengan top-level domain Google selain itu (seperti google.co.uk dan sebagainya)
  • Klien masih bisa memaksa penggunaan SSL dengan mengakses https://encrypted.google.com/

Kesimpulan

Keterbatasan kapasitas bandwidth adalah masalah yang umum di Indonesia, oleh karena itu optimalisasi dan efesiensi penggunaan bandwidth adalah hal yang memegang peranan penting untuk memaksimalkan pengalaman klien atau user (users experiences) pada saat melakukan browsing. Dengan menonaktifkan Google SSL Search pada mikrotik, setidaknya kita dapat melakukan efisiensi bandwidth pada saat klien atau user melakukan pencarian lewat mesin telusur Google.

Referensi

 

Incoming search:
menonaktifkan ssl search google, non aktif ssl google maps, penelusuran ssl mati, Seting telusur aman tanpa filter


Related Posts

Filed under

Mikrotik, Networking

| Tags:

Leave a comment ?

16 Comments.

  1. kalau untuk menonaktifkan ssl fb bisa ga mas?

  2. irwin wijaya lahusen

    Mau tanya…
    Saya ingin memby pass google search (google.com) di walled garden hotspot mikrotik.
    sudah berhasil. yang jadi masalah adalah semua yang menggunakan top domain google.com ikut terbuka, (google image search, google map, calender, mail.google, dll)

    setting saya di “walled garden IP list” port 80-443 protocol 80, dst host google.com, bukan di “walled garden”, soalnya nggak jadi kalau di “walled garden” mungkin karena IP dynamic .

    jadi solusinya bagaimana ?

    • susah untuk membatasi layanan google berdasarkan domain, karena layanan google kebanyakan menggunakan subdomain, contoh: maps.google.com, apps.google.com, dst. jadi kalo di allow .google.com, secara otomatis subdomainnya juga ikutan di allow.

  3. kalau pakai unbound gmana mas

  4. mas saya pernah berhasil dengan settingan di atas :

    /ip dns static
    add address=216.239.32.20 name=www.google.com
    add address=216.239.32.20 name=www.google.co.id

    tp kok skg gak work ya.., saya pake unbound. dan sudah saya tambahkan di file /etc/hosts:
    216.239.32.20 http://www.google.co.id

    Tapi masih belum work. ada solusinya gak mas? apa ada perubahan settingan?

    Terima kasih

  5. Maaf mas dijaringan saya masih belom solved. Tp ini permasalahanya di Squid Proxy saya sih mas, karena kalau PC Squid proxynya saya matikan (tanpa proxy) google ssl ini berhasil disable. tp kalau PC squid proxynya saya nyalakan lagi, Google SSL ini aktif lagi, alias setingan dimikrotik tidak berfungsi. padahal di file /etc/hosts sudah saya tambahkan seperti saranya mas

    216.239.32.20 http://www.google.co.id
    216.239.32.20 http://www.google.com

    Maaf mas saya kan pemula nih, jadi setingan cuma bisa copas aja, saya install Squid Proxy Lusca Head 14942 di Ubuntu 12.04.3 LTS 64bit dengan spek PC AMD Athlon ii x2 260 RAM 4GB HDD 500GB.

    sebelumnya saya minta saran nih, apa saya harus install ulang lagi PC proxy ini, klo pun iya bolehkah saya minta tutorial lengkapnya untuk install Squid + Unbound untk kebutuhan warnet saya.

    oh iya mas, kenapa facebook diwarnet saya sekarang selalu pakai https, padahal di setingan facebooknya jelajah aman sudah di nonaktifkan.

    sebelumnya terima kasih, maaf merepotkan

    • di mikrotik terdapat built-in dns resolver dan cache dns, oleh karena itu dari pada melakukan setup / instalasi unbound, menurut saya akan lebih mudah jika kita menggunakan layanan dns di mikrotik tersebut. misalkan ip mikrotik 192.168.5.1, silakan tambahkan pada konfigurasi squid :

      dns_nameservers 192.168.5.1 202.134.1.10 202.134.0.155

      dan pada /etc/resolv.conf

      nameserver 192.168.5.1

      spesifikasi server proxy nya sudah cukup bagus untuk lingkup warnet dan gamecenter. untuk perkara facebook yg https, sudah di informasikan di facebook bahwa mereka akan “memaksakan” penggunaan https jika memungkinkan (walaupun jelajah aman sudah di nonaktifkan).

  6. IP mikrotik ke Proxy : 192.168.3.0/24
    IP Proxy : 192.168.3.2
    Gateway Proxy : 192.168.3.1

    Di squid.conf sudah saya tambahkan :
    dns_nameservers 192.168.3.1 202.134.1.10 202.134.0.155

    dan pada /etc/resolv.conf sudah saya ubah jadi :

    nameserver 192.168.3.1

    dan opsi pada /etc/network/interfaces sudah saya hapus :
    # dns-* options are implemented by the resolvconf package, if installed
    dns-nameservers 127.0.0.1

    akan tetapi, setelah PC proxy di reboot / /etc/init.d/unbound restart

    opsi pada /etc/resolv.conf berubah lagi menjadi:

    nameserver 127.0.0.1

    permasalahanya dimana ya mas? Kondisi unbound normal gak ada masalah.

    Dan akhirnya solved setelah unbound saya remove, dst-nat 53 dimikrotik saya arahkan ke DNS Mikrotik, akan tetapi opsi nameserver 192.168.3.1 pada /etc/resolv.conf hilang setelah PC Proxy direstart.

  7. atau dengan cara menyampingkan DNS Unbound, dengan memaksa client untuk memakai DNS Mikrotik dengan dnt-nat : 3 ;;; #TRANSPARENT-DNS
    chain=dstnat action=redirect to-ports=53 protocol=udp dst-port=53

    4 ;;; #TRANSPARENT-DNS
    chain=dstnat action=redirect to-ports=53 protocol=tcp dst-port=53

    jadi Transparent DNS Unbound saya disable. dan di sisi squid dan unbound. setinganya tidak merubah. akan tetapi dengan setingan ini DNS resolver unbound di squid sama ja gak kepake kan mas? Mohon solusinya mas

    • bisa juga dengan mengganti forward-addr di unbound menggunakan ip mikrotik, jadi unbound tetap bisa dipakai sebagai rekursif dns di mesin proxy nya.

      forward-addr: 192.168.3.1

  8. karena saya mengaktifkan Rewriter SafeSearch disquid. jadi kl google SSL ini aktif. client bisa browsing dengan https dan porn baik di pencarian google atau youtube masih ketemu.

    • hmm.. untuk tujuan spesifik, seperti blocking porn, mas muhsan bisa coba pake squidguard. oh iya, selama mas pake dns telkom yg udah ada content filtering, biasanya porn udah keblokir kok sama internet positif. kecuali mas pake dns lainnya (seperti dns google).

  9. Kang buatin cara pake squid sama unbound di Windows dong..

    Buat yang ga pake mikrotik
    bisa pake link ini
    http://www.google.com/webhp?nord=1
    http://www.google.com/imghp?nord=1
    atau edit default serach engine nya jadi
    http://www.google.com/webhp?nord=1&q=%s

Leave a Comment

Current day month ye@r *