tunnel

Cara Tunneling IPv6 di MikroTik Menggunakan Tunnel Broker

Ditulis oleh Beri komentar Lihat komentar

Saat ini perkembangan penggunaan IPv6 di internet sudah semakin populer, karena alokasi IPv4 yang sudah mulai hampir out of stock. Sayangnya, tidak semua ISP di Indonesia (seperti halnya TelkomSpeedy) mendukung penggunaan dual stack IPv6 dan IPv4, sehingga akses user internet yang menggunakan IPv6 di Indonesia masih sangat rendah jumlahnya. Jika sobat adalah pemakai router berbasis MikroTik, maka trik tunneling IPv6 yang akan saya jabarkan disini mungkin akan membantu sobat untuk mengatasi hal tersebut.

Persiapan

Langkah pertama untuk melakukan tunneling IPv6 di mikrotik adalah mendaftarkan diri anda ke IPv6 tunnel broker yang dapat anda gunakan secara gratis. Ada beberapa tunnel gratisan yang dapat anda pilih, silakan lihat daftarnya dihalaman wiki berikut ini.

Dalam tutorial tunneling IPv6 di mikrotik berikut ini saya menggunakan perangkat RB450G yang sudah menggunakan RouterOS versi 6 keatas (mendukung penggunakan fitur 4to6), dan telah mendaftarkan diri di Tunnel Broker yang dikelola oleh Hurricane Electric (HE). Jika RouterOS anda belum mendukung fitur 4to6, silakan upgrade RouterOS sobat ke versi yang paling baru.

Pengaturan Tunnel Broker

Setelah sobat terdaftar di Tunnel Broker, selanjutnya ikuti petunjuk berikut ini :

  1. Create Regular Tunnel” isikan IPv4 Endpoint dengan alamat IPv4 statik yang diberikan oleh ISP kepada sobat
  2. Pilih opsi “Singapore” pada bagian Available tunnel server (karena Singapore routingnya lebih dekat ke Indonesia)
  3. Terakhir klik “Create tunnel”

Oke.. pembuatan tunnel sudah selesai. Selanjutnya sobat akan diarahkan ke halaman yang berisi informasi tentang tunnel yang barusan sobat buat, seperti yang terlihat pada screenshot berikut ini :

tunneling ipv6 di mikrotik

Contoh parameter tunnel IPv6 yang telah dibuat

Silakan catat parameter-parameter tersebut di notepad :)

Pengaturan tunneling ipv6 disisi Mikrotik

Pertama, aktifkan IPv6 dan 4to6 di mikrotik kesayangan anda (khusus untuk sobat yang belum mengaktifkan IPv6).

/system package enable ipv6
/system reboot

Next… copas, copas, copas!! Di halaman informasi tunnel yang telah sobat buat, klik pada tab pilihan “Example Configuration”, kemudian pilih “Mikrotik” pada menu dropdown yang tersedia. Copy – paste command yang telah di generate oleh tunnel broker ke terminal mikrotik yang sobat miliki.

/interface 6to4 add comment="Hurricane Electric IPv6 Tunnel Broker" disabled=no local-address=110.xxx.xxx.xxx mtu=1280 name=sit1 remote-address=216.218.221.42
/ipv6 route add comment="" disabled=no distance=1 dst-address=2000::/3 gateway=2001:47x:xx:xxx::1 scope=30 target-scope=10
/ipv6 address add address=2001:47x:xx:xxx::2/64 advertise=yes disabled=no eui-64=no interface=sit1

Thats it! Saat ini seharusnya sobat sudah bisa menggunakan fungsi tunneling IPv6 di mikrotik dengan baik. Langkah selanjutnya untuk memastikan tunneling udah bisa dipake, coba nge-ping ke IPv6 eksternal (dalam contoh ini saya nge-ping ke IPv6 server DNS milik Google).

[fazar@mikrotik] > ping 2001:4860:4860::8844
HOST SIZE TTL TIME STATUS
2001:4860:4860::8844 56 58 36ms echo reply
2001:4860:4860::8844 56 58 35ms echo reply
2001:4860:4860::8844 56 58 46ms echo reply
sent=3 received=3 packet-loss=0% min-rtt=35ms avg-rtt=39ms max-rtt=46ms

Setting tunneling IPv6 di mikrotik sudah selesai, nah selanjutnya adalah mengaktifkan IPv6 pada interface yang mengarah ke klien. Untuk melakukan hal ini, kita bisa menggunakan alokasi route prefiks IPv6 (Routed /64) yang diberikan oleh tunnel broker dan sudah sobat catat sebelumnya di notepad, kemudian melakukan advertisements ke komputer klien.

Misalnya Routed /64 tunnel : 2001:471:56:ade::/64

Interface yang mengarah klien dapat kita berikan IPv6 2001:471:56:ade:1:/64 (perhatikan ada angka 1 di ujung nya)

Copas command berikut ini ke terminal mikrotik (perhatikan interface yang mengarah ke klien! Dalam contoh ini saya menggunakan interface dengan nama “LAN”).

/ipv6 address add interface="LAN" address="2001:471:56:ade:1:/64" advertise=yes

Biarkan mikrotik melakukan advertise IPv6 kurang lebih 5 menit, kemudian coba ping IPv6 eksternal dari klien. It should works! :)

Catatan :

Dalam pengalaman saya, hanya klien dengan OS tertentu / terbaru yang dapat menerima advertise IPv6 dengan baik dan benar (Ubuntu Desktop, Windows 7, Windows 8) sedangkan klien dengan OS jadul (seperti Windows XP) tidak dapat mengimplentasikan IPv6 yang di advertise oleh mikrotik secara otomatis.

tunneling ipv6 di mikrotik

Contoh hasil nge-ping IPv6 dari klien

Pengaturan tunneling IPv6 di mikrotik dengan cara seperti ini hanya berlaku jika sobat menggunakan IPv4 statik yang diberikan oleh ISP. Bagaimana jika sobat diberikan IPv4 dynamic oleh ISP?

Sedikit petunjuk buat yang pake IPv4 dinamik:

  • http://wiki.mikrotik.com/wiki/Dynamic_DNS_Update_Script_for_dynDNS
  • https://www.tunnelbroker.net/forums/index.php?topic=1994.0

Silakan oprek script diatas :)

Demikian sedikit ulasan saya mengenai cara tunneling IPv6 di mikrotik menggunakan tunnel broker dari Hurricane Electric. Semoga bermanfaat dan jangan lupa klik share/like jika tutorial kecil ini bermanfaat untuk sobat.


Related Posts

Filed under

Mikrotik

| Tags:

  1. thanks share nya..

Leave a Comment